All systems operational

Scheduled Maintenance: Wednesday, March 20th, 2024 – 19:00 CET/CEST

Completed
Scheduled for 20 March 2024 at 6:00 PM – 8:00 PM

Affects

Production
Web App (https://app.trever.io)
API Rest
API Websocket
Updates
  • Completed
    20 March 2024 at 8:00 PM
    Completed
    20 March 2024 at 8:00 PM
    Maintenance has completed successfully
  • In progress
    20 March 2024 at 6:00 PM
    In progress
    20 March 2024 at 6:00 PM
    Maintenance is now in progress
  • Planned
    20 March 2024 at 6:00 PM
    Planned
    20 March 2024 at 6:00 PM

    To roll out our latest release, Trever is scheduled for maintenance on

    Wednesday, March 20th, 2024 – 19:00 CET/CEST.

    Please expect higher latencies and limited availability as long as the maintenance is scheduled.

    Please note: We strongly advise you, to stop trading activities and/or transaction and transfer activities during the scheduled maintenance.

    Our release notes will be updated shortly before release. Check out what's new.