Scheduled Maintenance: Wednesday, March 19th, 2025 – 19:00 CE(S)T
Scheduled for 19 March 2025 at 6:00 PM – 7:08 PM
Affects
Trever Services
Under maintenance from 6:00 PM to 7:08 PM
Trever Console (https://app.trever.io)
Under maintenance from 6:00 PM to 7:08 PM
Trever Public API Rest
Under maintenance from 6:00 PM to 7:08 PM
Trever Pro API Rest
Under maintenance from 6:00 PM to 7:08 PM
Trever Websockets
Under maintenance from 6:00 PM to 7:08 PM
Completed
19 March 2025 at 7:08 PMCompleted
19 March 2025 at 7:08 PMMaintenance has completed successfully.
In progress
19 March 2025 at 6:00 PMIn progress
19 March 2025 at 6:00 PMMaintenance is now in progress
Planned
19 March 2025 at 6:00 PMPlanned
19 March 2025 at 6:00 PMTo roll out our latest changes, improvements and security patches, Trever is scheduled for maintenance on
Wednesday, March 19th, 2025 – 19:00 CE(S)T.
Please expect higher latencies and limited availability as long as the maintenance is scheduled.
Please note: We recommend stopping trading activities and/or transaction and transfer activities during the scheduled maintenance.
Our release notes will be updated shortly before release. Check out what's new.